lizongbo at 618119.com 工作,生活,Android,前端,Linode,Ubuntu,nginx,java,apache,tomcat,Resin,mina,Hessian,XMPP,RPC

2009年07月13日

在64位 Ubuntu 9.04 上编译Firefox 3.5

Filed under: Linux — 标签:, , , — lizongbo @ 00:40

在64位 9.04 上编译Firefox 3.5

在64位的ubuntu9.04上面使用解压版的Firefox3.5,没法使用64位的Flash插件,命令行下运行可以看到类似下面的错误信息:

lizongbo@lizongbo-nb1:/opt/$ ./
Gtk-Message: Failed to load module “canberra-gtk-module”: /usr/lib/gtk-2.0/modules/libcanberra-gtk-module.so: wrong ELF class: ELFCLASS64
Gtk-Message: Failed to load module “canberra-gtk-module”: /usr/lib/gtk-2.0/modules/libcanberra-gtk-module.so: wrong ELF class: ELFCLASS64
nsHeaderInfo: registerSelf called!
nsHeaderInfo: registerSelf called!
/usr/lib/gio/modules/libgiogconf.so: wrong ELF class: ELFCLASS64
Failed to load module: /usr/lib/gio/modules/libgiogconf.so
/usr/lib/gio/modules/libgvfsdbus.so: wrong ELF class: ELFCLASS64
Failed to load module: /usr/lib/gio/modules/libgvfsdbus.so
/usr/lib/gio/modules/libgioremote-volume-monitor.so: wrong ELF class: ELFCLASS64
Failed to load module: /usr/lib/gio/modules/libgioremote-volume-monitor.so
LoadPlugin: failed to initialize shared library /home/lizongbo/.mozilla/plugins/libflashplayer.so [/home/lizongbo/.mozilla/plugins/libflashplayer.so: wrong ELF class: ELFCLASS64]

因此选择编译代码进行安装:

1.下载源代码:

http://releases.mozilla.org/pub/mozilla.org/firefox/releases/3.5/source/firefox-3.5-source.tar.bz2

2.解压 firefox-3.5-source.tar.bz2到 /opt下面:

lizongbo@lizongbo-nb1:/opt/mozilla-1.9.1$ pwd
/opt/mozilla-1.9.1

3.到/opt/mozilla-1.9.1下,运行

./configure –enable-application=browser

根据报错的信息,安装需要的相关库。
大概主要有build-essential 等:
因此运行以下命令安装苦文件:
sudo apt-get install build-essential autoconf automake1.9

sudo apt-get install  libasound2-dev

sudo apt-get install libdbus-glib-1-dev

sudo apt-get install libglib2.0-dev

4.保证./configure –enable-application=browser 能够通过之后,
运行 sudo make ,编译过程需要很长时间,这个时候出去逛一下再回来。
//lizongbo@lizongbo-nb1:/opt/mozilla-1.9.1$ sudo make

5.等make完成了,运行
sudo make install
//lizongbo@lizongbo-nb1:/opt/mozilla-1.9.1$ sudo make install

这个时候安装好了,从菜单里启动的时候不再是firefox3.0.11了。
但是界面是英文的。

6.下载Firefox linux版的中文语言包:

http://releases.mozilla.org/pub/mozilla.org/firefox/releases/3.5/linux-i686/xpi/zh-CN.xpi

7.安装之后重启,节目仍然是英文的,这个英文默认编译的属性是英文的。
在地址栏输入:about:config。
然后搜索general.useragent.locale。找到之后,将默认的en-US改成zh-CN,注意是减号不是下划线。

然后重启,中文版的Firefox界面出来了。

8.下载flash64位版插件,下载地址为:
http://download.macromedia.com/pub/labs/flashplayer10/libflashplayer-10.0.22.87.linux-x86_64.so.tar.gz

解压libflashplayer-10.0.22.87.-x86_64.so.tar.gz将libflashplayer.so复制到用户主目录的.mozilla/plugins,即:~/.mozilla/plugins.

(Ubuntu下flash乱码的解决方法为删除49-sansserif.conf,执行下面的命令即可:
cd /etc/fonts/conf.d/
sudo cp 49-sansserif.conf 49-sansserif.conf_backup
sudo rm 49-sansserif.conf)

9.访问谷歌的音乐搜索:
http://www.google.cn/music/songscreener

可以看到flash显示正常。

2 Comments »

  1. 过来支持一下,话说都快荒废了,你这个blog

    Reply

    lizongbo reply on 二月 13th, 2010:

    自换工作后一直在忙碌,2010年会好点,会继续博

    评论 by cosbeta — 2010年02月9日 @ 11:59

RSS feed for comments on this post. TrackBack URL

Leave a comment

Powered by WordPress